# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<\[[^a-zA-Z0-9]*\]\.{1})(\.{1}\[[a-zA-Z0-9]*\]\.{1})*"
test_str = ("<[{]..[7]..[]..[]..[C2I43].\n"
"<[(_#/}$)$]..[GO5A]..[G5]..[3W4].\n"
"<[^]..[54]..[S].\n"
"<[@].\n"
"<[)$-{,]..[PB1N]..[R757G].\n"
"<[]..[]..[10]..[223F]..[GBM4].\n"
"<[!]..[]\n"
"<[)_]..[3N]..[TS]..[0NS58].")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.