using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(?=.*\bhede\b)).*$";
string input = @"hoho
hihi
haha
hede
some words before hoho some words after that
some words before hihi some words after that
some words before haha some words after that
some words before hede some words after that
ahede";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}