re = /^(?!(?=.*\bhede\b)).*$/m
str = 'hoho
hihi
haha
hede
some words before hoho some words after that
some words before hihi some words after that
some words before haha some words after that
some words before hede some words after that
ahede'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end