import re
regex = re.compile(r"^(?!(?=.*\bhede\b)).*$", flags=re.MULTILINE)
test_str = ("hoho\n"
"hihi\n"
"haha\n"
"hede\n"
"some words before hoho some words after that\n"
"some words before hihi some words after that\n"
"some words before haha some words after that\n"
"some words before hede some words after that\n"
"ahede")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")