using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[a-z]+[a-z89]+[a-z]+|[a-z]+)[9]?";
string input = @"aaa898a8 a8a8a8a8 9aaaa9a9 8aaaa8a89 aa99 aaa8a98";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}