$re = '/(?:[a-z]+[a-z89]+[a-z]+|[a-z]+)[9]?/m';
$str = 'aaa898a8 a8a8a8a8 9aaaa9a9 8aaaa8a89 aa99 aaa8a98';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);