use strict;
my $str = 'aaa898a8 a8a8a8a8 9aaaa9a9 8aaaa8a89 aa99 aaa8a98';
my $regex = qr/(?:[a-z]+[a-z89]+[a-z]+|[a-z]+)[9]?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}