const regex = /(?:[a-z]+[a-z89]+[a-z]+|[a-z]+)[9]?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[a-z]+[a-z89]+[a-z]+|[a-z]+)[9]?', 'gm')
const str = `aaa898a8 a8a8a8a8 9aaaa9a9 8aaaa8a89 aa99 aaa8a98`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}