package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[a-z]+[a-z89]+[a-z]+|[a-z]+)[9]?`)
var str = `aaa898a8 a8a8a8a8 9aaaa9a9 8aaaa8a89 aa99 aaa8a98`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}