#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=PRODUCT DESCRIPTION)((.|\n)*)(",)"
Local $sString = "11111,"testing","PRODUCT DESCRIPTION" & @CRLF & _
"Sample Description.",,31.350000,31.35,31" & @CRLF & _
"11111,"testing","PRODUCT DESCRIPTION" & @CRLF & _
"Sample Description.",,31.350000,31.35,31" & @CRLF & _
"11111,"testing","PRODUCT DESCRIPTION" & @CRLF & _
"Sample Description.",,31.350000,31.35,31"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")