using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=PRODUCT DESCRIPTION)((.|\n)*)("",)";
string input = @"11111,""testing"",""PRODUCT DESCRIPTION
Sample Description."",,31.350000,31.35,31
11111,""testing"",""PRODUCT DESCRIPTION
Sample Description."",,31.350000,31.35,31
11111,""testing"",""PRODUCT DESCRIPTION
Sample Description."",,31.350000,31.35,31";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}