$re = '/(?=PRODUCT DESCRIPTION)((.|\n)*)(",)/';
$str = '11111,"testing","PRODUCT DESCRIPTION
Sample Description.",,31.350000,31.35,31
11111,"testing","PRODUCT DESCRIPTION
Sample Description.",,31.350000,31.35,31
11111,"testing","PRODUCT DESCRIPTION
Sample Description.",,31.350000,31.35,31';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);