re = /(?=PRODUCT DESCRIPTION)((.|\n)*)(",)/
str = '11111,"testing","PRODUCT DESCRIPTION
Sample Description.",,31.350000,31.35,31
11111,"testing","PRODUCT DESCRIPTION
Sample Description.",,31.350000,31.35,31
11111,"testing","PRODUCT DESCRIPTION
Sample Description.",,31.350000,31.35,31'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end