import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=PRODUCT DESCRIPTION)((.|\\n)*)(\",)";
final String string = "11111,\"testing\",\"PRODUCT DESCRIPTION\n"
+ "Sample Description.\",,31.350000,31.35,31\n"
+ "11111,\"testing\",\"PRODUCT DESCRIPTION\n"
+ "Sample Description.\",,31.350000,31.35,31\n"
+ "11111,\"testing\",\"PRODUCT DESCRIPTION\n"
+ "Sample Description.\",,31.350000,31.35,31";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}