using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/\/[0-9a-zA-Z\.\/_-]+\.(?:jp(?:e?g|e|2)|gif|png|tiff?|bmp|ico))";
string input = @"Hello world! //some/any/ollolo.jpg asdasd";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}