$re = '/(\/\/[0-9a-zA-Z\.\/_-]+\.(?:jp(?:e?g|e|2)|gif|png|tiff?|bmp|ico))/i';
$str = 'Hello world! //some/any/ollolo.jpg asdasd';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);