const regex = /(\/\/[0-9a-zA-Z\.\/_-]+\.(?:jp(?:e?g|e|2)|gif|png|tiff?|bmp|ico))/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/\\\/[0-9a-zA-Z\\.\\\/_-]+\\.(?:jp(?:e?g|e|2)|gif|png|tiff?|bmp|ico))', 'i')
const str = `Hello world! //some/any/ollolo.jpg asdasd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}