re = /(\/\/[0-9a-zA-Z\.\/_-]+\.(?:jp(?:e?g|e|2)|gif|png|tiff?|bmp|ico))/i
str = 'Hello world! //some/any/ollolo.jpg asdasd'
# Print the match result
str.match(re) do |match|
puts match.to_s
end