// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(\/\/[0-9a-zA-Z\.\/_-]+\.(?:jp(?:e?g|e|2)|gif|png|tiff?|bmp|ico))").unwrap();
let string = "Hello world! //some/any/ollolo.jpg asdasd";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}