#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^.*?Thing #\d+(?:(?!hidden=(?:true|false))[\S\s])*?hidden=false"
Local $sString = "Thing #1" & @CRLF & _
"........." & @CRLF & _
"hidden=true" & @CRLF & _
"........." & @CRLF & _
"Thing #2" & @CRLF & _
"........." & @CRLF & _
"hidden=false" & @CRLF & _
"........."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")