$re = '/^.*?Thing #\d+(?:(?!hidden=(?:true|false))[\S\s])*?hidden=false/';
$str = 'Thing #1
.........
hidden=true
.........
Thing #2
.........
hidden=false
.........';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);