re = /^.*?Thing #\d+(?:(?!hidden=(?:true|false))[\S\s])*?hidden=false/
str = 'Thing #1
.........
hidden=true
.........
Thing #2
.........
hidden=false
.........'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end