const regex = /^.*?Thing #\d+(?:(?!hidden=(?:true|false))[\S\s])*?hidden=false/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?Thing #\\d+(?:(?!hidden=(?:true|false))[\\S\\s])*?hidden=false', 'g')
const str = `Thing #1
.........
hidden=true
.........
Thing #2
.........
hidden=false
.........`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}