using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?Thing #\d+(?:(?!hidden=(?:true|false))[\S\s])*?hidden=false";
string input = @"Thing #1
.........
hidden=true
.........
Thing #2
.........
hidden=false
.........";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}