# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b([A-Z][a-z]+)\b(?<=^[^A-Z]*\b\1\b.*)/Foo/gm;t' <<< "Anne, Lisa and Paul went to the store, then Anne said to Paul: \"I love Lisa!\". Then Lisa laughed and kissed Anne.
anne, Lisa and Paul went to the store, then Anne said to Paul: \"I love Lisa!\". Then Lisa laughed and kissed Anne.
anne, lisa and Paul went to the store, then Anne said to Paul: \"I love Lisa!\". Then Lisa laughed and kissed Anne."