using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([A-Z][a-z]+)\b(?<=^[^A-Z]*\b\1\b.*)";
string substitution = @"Foo";
string input = @"Anne, Lisa and Paul went to the store, then Anne said to Paul: ""I love Lisa!"". Then Lisa laughed and kissed Anne.
anne, Lisa and Paul went to the store, then Anne said to Paul: ""I love Lisa!"". Then Lisa laughed and kissed Anne.
anne, lisa and Paul went to the store, then Anne said to Paul: ""I love Lisa!"". Then Lisa laughed and kissed Anne.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}