$re = '/\b([A-Z][a-z]+)\b(?<=^[^A-Z]*\b\1\b.*)/m';
$str = 'Anne, Lisa and Paul went to the store, then Anne said to Paul: "I love Lisa!". Then Lisa laughed and kissed Anne.
anne, Lisa and Paul went to the store, then Anne said to Paul: "I love Lisa!". Then Lisa laughed and kissed Anne.
anne, lisa and Paul went to the store, then Anne said to Paul: "I love Lisa!". Then Lisa laughed and kissed Anne.';
$subst = "Foo";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;