import re
regex = re.compile(r"\b([A-Z][a-z]+)\b(?<=^[^A-Z]*\b\1\b.*)", flags=re.MULTILINE)
test_str = ("Anne, Lisa and Paul went to the store, then Anne said to Paul: \"I love Lisa!\". Then Lisa laughed and kissed Anne.\n\n"
"anne, Lisa and Paul went to the store, then Anne said to Paul: \"I love Lisa!\". Then Lisa laughed and kissed Anne.\n\n"
"anne, lisa and Paul went to the store, then Anne said to Paul: \"I love Lisa!\". Then Lisa laughed and kissed Anne.")
subst = "Foo"
result = regex.sub(subst, test_str)
if result:
print(result)