const regex = /\b([A-Z][a-z]+)\b(?<=^[^A-Z]*\b\1\b.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([A-Z][a-z]+)\\b(?<=^[^A-Z]*\\b\\1\\b.*)', 'gm')
const str = `Anne, Lisa and Paul went to the store, then Anne said to Paul: "I love Lisa!". Then Lisa laughed and kissed Anne.
anne, Lisa and Paul went to the store, then Anne said to Paul: "I love Lisa!". Then Lisa laughed and kissed Anne.
anne, lisa and Paul went to the store, then Anne said to Paul: "I love Lisa!". Then Lisa laughed and kissed Anne.`;
const subst = `Foo`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);