#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Wordle\s(?P<number>\d+)\s(?P<tries>[1-6X])\/6(?:\r?\n){2}(?P<evaluations>(?:[⬛🟨🟩]{5}(?:\r?\n)){0,5})(?P<result>[⬛🟨🟩]{5})"
Local $sString = "Tests:" & @CRLF & _
"" & @CRLF & _
"Wordle 249 1/6" & @CRLF & _
"" & @CRLF & _
"🟩🟩🟩🟩🟩" & @CRLF & _
"" & @CRLF & _
"Wordle 251 6/6" & @CRLF & _
"" & @CRLF & _
"⬛⬛⬛⬛⬛" & @CRLF & _
"⬛⬛🟨⬛⬛" & @CRLF & _
"⬛⬛🟨⬛⬛" & @CRLF & _
"⬛🟩🟩🟩⬛" & @CRLF & _
"⬛⬛⬛⬛⬛" & @CRLF & _
"🟩🟩🟩🟩🟩" & @CRLF & _
"" & @CRLF & _
"Wordle 247 1/6" & @CRLF & _
"" & @CRLF & _
"🟩🟩🟩🟩🟩" & @CRLF & _
"" & @CRLF & _
"Wordle 1 5/6" & @CRLF & _
"" & @CRLF & _
"⬛⬛⬛⬛⬛" & @CRLF & _
"⬛🟨⬛🟨🟨" & @CRLF & _
"⬛🟨⬛⬛⬛" & @CRLF & _
"🟨🟨🟨🟨🟨" & @CRLF & _
"🟩🟩🟩🟩🟩" & @CRLF & _
"" & @CRLF & _
"Wordle 999 X/6" & @CRLF & _
"" & @CRLF & _
"🟨🟩⬛⬛⬛" & @CRLF & _
"🟨🟩⬛⬛⬛" & @CRLF & _
"🟨🟩⬛⬛⬛" & @CRLF & _
"🟨🟩⬛⬛⬛" & @CRLF & _
"🟨🟩⬛⬛⬛" & @CRLF & _
"🟨🟩⬛⬛⬛"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")