import Foundation
let pattern = #"Wordle\s(?P<number>\d+)\s(?P<tries>[1-6X])\/6(?:\r?\n){2}(?P<evaluations>(?:[⬛🟨🟩]{5}(?:\r?\n)){0,5})(?P<result>[⬛🟨🟩]{5})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Tests:
Wordle 249 1/6
🟩🟩🟩🟩🟩
Wordle 251 6/6
⬛⬛⬛⬛⬛
⬛⬛🟨⬛⬛
⬛⬛🟨⬛⬛
⬛🟩🟩🟩⬛
⬛⬛⬛⬛⬛
🟩🟩🟩🟩🟩
Wordle 247 1/6
🟩🟩🟩🟩🟩
Wordle 1 5/6
⬛⬛⬛⬛⬛
⬛🟨⬛🟨🟨
⬛🟨⬛⬛⬛
🟨🟨🟨🟨🟨
🟩🟩🟩🟩🟩
Wordle 999 X/6
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)