const regex = new RegExp('Wordle\\s(?P<number>\\d+)\\s(?P<tries>[1-6X])\\/6(?:\\r?\\n){2}(?P<evaluations>(?:[⬛🟨🟩]{5}(?:\\r?\\n)){0,5})(?P<result>[⬛🟨🟩]{5})', 'g')
const str = `Tests:
Wordle 249 1/6
🟩🟩🟩🟩🟩
Wordle 251 6/6
⬛⬛⬛⬛⬛
⬛⬛🟨⬛⬛
⬛⬛🟨⬛⬛
⬛🟩🟩🟩⬛
⬛⬛⬛⬛⬛
🟩🟩🟩🟩🟩
Wordle 247 1/6
🟩🟩🟩🟩🟩
Wordle 1 5/6
⬛⬛⬛⬛⬛
⬛🟨⬛🟨🟨
⬛🟨⬛⬛⬛
🟨🟨🟨🟨🟨
🟩🟩🟩🟩🟩
Wordle 999 X/6
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}