// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Wordle\s(?P<number>\d+)\s(?P<tries>[1-6X])\/6(?:\r?\n){2}(?P<evaluations>(?:[⬛🟨🟩]{5}(?:\r?\n)){0,5})(?P<result>[⬛🟨🟩]{5})").unwrap();
let string = "Tests:
Wordle 249 1/6
🟩🟩🟩🟩🟩
Wordle 251 6/6
⬛⬛⬛⬛⬛
⬛⬛🟨⬛⬛
⬛⬛🟨⬛⬛
⬛🟩🟩🟩⬛
⬛⬛⬛⬛⬛
🟩🟩🟩🟩🟩
Wordle 247 1/6
🟩🟩🟩🟩🟩
Wordle 1 5/6
⬛⬛⬛⬛⬛
⬛🟨⬛🟨🟨
⬛🟨⬛⬛⬛
🟨🟨🟨🟨🟨
🟩🟩🟩🟩🟩
Wordle 999 X/6
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}