# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/!!rlang::sym\("([^"]+)"\)/$1/gm;t' <<< "function(data, x = !!rlang::sym(\"Time1\"), y = !!rlang::sym(\"YVAR\")), values = c(\"a\", \"b\"))"