package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)!!rlang::sym\("([^"]+)"\)`)
var str = `function(data, x = !!rlang::sym("Time1"), y = !!rlang::sym("YVAR")), values = c("a", "b"))`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}