#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)!!rlang::sym\("([^"]+)"\)"
Local $sString = "function(data, x = !!rlang::sym("Time1"), y = !!rlang::sym("YVAR")), values = c("a", "b"))"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)