using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"!!rlang::sym\(""([^""]+)""\)";
string substitution = @"$1";
string input = @"function(data, x = !!rlang::sym(""Time1""), y = !!rlang::sym(""YVAR"")), values = c(""a"", ""b""))";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}