import Foundation
let pattern = #"!!rlang::sym\("([^"]+)"\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"function(data, x = !!rlang::sym("Time1"), y = !!rlang::sym("YVAR")), values = c("a", "b"))"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)