#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!SS|FF|PP).*(\d{1,2}[,.]\d{1,2})$"
Local $sString = "CC 1,00" & @CRLF & _
"SS 1,00" & @CRLF & _
"PP 1,00" & @CRLF & _
"1,00" & @CRLF & _
"FF 1,00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")