const regex = /^(?!SS|FF|PP).*(\d{1,2}[,.]\d{1,2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!SS|FF|PP).*(\\d{1,2}[,.]\\d{1,2})$', 'gm')
const str = `CC 1,00
SS 1,00
PP 1,00
1,00
FF 1,00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}