import re
regex = re.compile(r"^(?!SS|FF|PP).*(\d{1,2}[,.]\d{1,2})$", flags=re.MULTILINE)
test_str = ("CC 1,00\n"
"SS 1,00\n"
"PP 1,00\n"
"1,00\n"
"FF 1,00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")