import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!SS|FF|PP).*(\\d{1,2}[,.]\\d{1,2})$";
final String string = "CC 1,00\n"
+ "SS 1,00\n"
+ "PP 1,00\n"
+ "1,00\n"
+ "FF 1,00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}