# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<{\s*foreach\(\s*\$(?<variable>\w+)\s+as\s+\$(?<value>\w+)\s*\)\s*}>(?<body>.+)<{\s*endforeach\s*}>//si;t' <<< "<ul class=\"row\">
<{ foreach( $users as $user ) }>
<li><{ $user }></li>
<{ endforeach }>
</ul>"