import re
regex = re.compile(r"<{\s*foreach\(\s*\$(?<variable>\w+)\s+as\s+\$(?<value>\w+)\s*\)\s*}>(?<body>.+)<{\s*endforeach\s*}>", flags=re.DOTALL | re.IGNORECASE)
test_str = ("<ul class=\"row\">\n"
" <{ foreach( $users as $user ) }>\n"
" <li><{ $user }></li>\n"
" <{ endforeach }>\n"
"</ul>")
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)