re = /<{\s*foreach\(\s*\$(?<variable>\w+)\s+as\s+\$(?<value>\w+)\s*\)\s*}>(?<body>.+)<{\s*endforeach\s*}>/i
str = '<ul class="row">
<{ foreach( $users as $user ) }>
<li><{ $user }></li>
<{ endforeach }>
</ul>'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result