$re = '/<{\s*foreach\(\s*\$(?<variable>\w+)\s+as\s+\$(?<value>\w+)\s*\)\s*}>(?<body>.+)<{\s*endforeach\s*}>/si';
$str = '<ul class="row">
<{ foreach( $users as $user ) }>
<li><{ $user }></li>
<{ endforeach }>
</ul>';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;