const regex = /<{\s*foreach\(\s*\$(?<variable>\w+)\s+as\s+\$(?<value>\w+)\s*\)\s*}>(?<body>.+)<{\s*endforeach\s*}>/si;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<{\\s*foreach\\(\\s*\\$(?<variable>\\w+)\\s+as\\s+\\$(?<value>\\w+)\\s*\\)\\s*}>(?<body>.+)<{\\s*endforeach\\s*}>', 'si')
const str = `<ul class="row">
<{ foreach( \$users as \$user ) }>
<li><{ \$user }></li>
<{ endforeach }>
</ul>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);