import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(AAA|BBB|CCC|DDD)\\((([^()]*|\\([^()]*\\))*)\\)";
final String string = "one two 12AAA(CCC(C1_1);A1_1;DDD(145))dfg \n"
+ "dfgdfgdfg,BBB(B1_1; CCC(C1_1); B1_2) sfsgndf \n"
+ "dfgnhjdfglkjdfg DDD(D1_1)\n"
+ "CCC()\n\n"
+ "one two 12AAA(CCC(C1_1; DDD(D1_1));A1_1)dfg ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}