const regex = /(AAA|BBB|CCC|DDD)\((([^()]*|\([^()]*\))*)\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(AAA|BBB|CCC|DDD)\\((([^()]*|\\([^()]*\\))*)\\)', 'g')
const str = `one two 12AAA(CCC(C1_1);A1_1;DDD(145))dfg
dfgdfgdfg,BBB(B1_1; CCC(C1_1); B1_2) sfsgndf
dfgnhjdfglkjdfg DDD(D1_1)
CCC()
one two 12AAA(CCC(C1_1; DDD(D1_1));A1_1)dfg `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}