// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(AAA|BBB|CCC|DDD)\((([^()]*|\([^()]*\))*)\)").unwrap();
let string = "one two 12AAA(CCC(C1_1);A1_1;DDD(145))dfg
dfgdfgdfg,BBB(B1_1; CCC(C1_1); B1_2) sfsgndf
dfgnhjdfglkjdfg DDD(D1_1)
CCC()
one two 12AAA(CCC(C1_1; DDD(D1_1));A1_1)dfg ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}